Upgrade Java 1.4 to 1.5 on Centos 5.5

While trying to install Solr in Centos, I noticed that Java 1.5 is required, however Java 1.4 is installed by default.
Now, in order not to have Tomcat start the old Java version, we need to uninstall it using a simple yum line:

sudo yum remove java

Next on the list is to install the new Java versions. Good thing it is included :)

sudo yum install java-1.6.0-openjdk

and

yum install java-1.6.0-openjdk-devel

Finally, we are ready to install Tomcat:

sudo yum install -y tomcat5

Start tomcat with:

service tomcat5 start

Tags: 
Server configuration, CentOS

Recent Comments

Forward by Dries Buytaert, Founder and Project Lead, Drupal; CTO Acquia.

Order now from:

Managing Expectations Podcast with DrupalEasy

Author Interview http://tinyurl.com/8a8nxno

We provide the most Shiny Drupal Bits & Pixels

Since Drupal 4.x